WAMP refuse de démarrer !

Allez encore un petit maronnier du développeur web for dummies… 

Un grand classique des technos Apache/MySQL/PHP est l’étape d’installation d’un serveur local. Si, comme moi, vous êtes un être suffisamment classique pour ne pas travailler sur Mac, et pas suffisamment aventurier pour côtoyer Linux au jour le jour ; vous allez probablement le faire sur un PC Windows.

 

Houla ma brave dame mauvaise idée, c’est Windows tout de même !

Diantre quelque chose cloche entre le logiciel libre et Microsoft et il semble que ce dernier souhaite vous le faire payer le prix fort. Quelle idée aussi, faire du PHP sur une machine préinstallée avec IIS (l’Apache de nos petits amis microsoftiens). L’idée est effectivement saugrenue mais des solutions packagées comme WAMP sont là pour faire le travail… normalement.

Malgré la simplicité de l’action : télécharger WAMP depuis le site concerné, et patienter que le tout s’installe, il s’en suit comme un léger flottement au moment de lancer le bestiau. Le bon fonctionnement du serveur, ne sera indiqué que par cette très fameuse icone de 4px de côté. Autant dire que si vous voyez ce merveilleux W passer au vert du premier coup, estimez-vous heureux, bookmarké cet article au cas où, et continuez votre petit bonhomme de chemin.

Dans le cas contraire, vous avez probablement pesté un bon moment avant d’atterir ici. Vous avez probablement effectué une myriade de requêtes Google, vous indiquant plus ou moins simplement qu’il serait de bon ton de changer le port de Skype ou voire carrément de le désinstaller. Puis d’autres forums vous indiquent d’un ton débonnaire qu’il « suffit » de vérifier si le port 80 est bien libre sinon ma pauvre dame c’est normal que cela ne fonctionne pas.

Je vous passe également les douleurs anales à base de changement, plus ou moins abscons, dans des fichiers de configurations divers et variés (httpd.conf, php.ini et toute la clic).

Un brin vexé par tant de difficultés et ce alors que vous n’avez même pas encore touché une ligne de code, vous voilà en proie à une grande détresse et vous sentez un peu impuissant face à toutes ces réponses vagues, évasives ou carrément fausses, glanées sur le web.

 

Allez allez on range ses petites larmichettes, on reprend du poil de la bête et on tente un dernier truc.

Tout d’abord, commencez par cliquez sur cette icone damnée (probablement orange à l’heure où je vous parle). Je parle d’un clic gauche bien sûr, l’ergonomie de WAMP étant ce qu’elle est, vous aurez droits à des options différentes selon que vous utilisez l’un ou l’autre de vos clics.

Rendez-vous dans le menu Apache, puis le sous-menu Services puis cliquez sur « install services ».

Là vous devriez avoir une invite de commande vous précisant quelle est la « bordel-de-pompe-à-cul » d’application qui occupe ce très fameux port 80. Si vous avez bien modifié le port de Skype normalement cela devrait vous dire que IIS squatte gentiment là ou vous souhaiteriez bien qu’il rentre chez sa mère.

Pour le désactiver, rendez-vous dans le panneau de configuration, puis programmes et un bon clic des familles sur « activer désactiver des fonctionnalités de Windows ». Là vous décochez ce put… de « Internet Information Services« , vous validez, vous redémarrez et vous relancez WAMP. SI cela passe au vert, joie et félicité, vous pouvez aller vous coucher. Dans le cas contraire on continue le petit périple.

Pour savoir quel est le nouveau coupable qui squatte le port 80 (il commence sérieusement à nous saouler), on retourne deux étapes plus haut (menu Apache, services etc.) et l’on regarde quel est le petit mariole. Cela devrait être un certain trou de balle du nom de Microsoft-HTTPAPI/2.0.  Bon Papi il est bien gentil, mais va falloir penser aux médocs et au dodo.

La méthode pour le désactiver diverge un peu. Toujours dans le Panneau de configurations, modifiez l’affichage des icônes de catégories en « petites icones », histoire d’y voir plus clair, puis cliquez sur outils d’administration, puis cliquez sur Services.

Là on se concentre ça devient relou. Une fois dans la fenêtre Services vous allez avoir une liste de tout le fatras qui tourne sur votre PC. Je vous invite à filtrer la liste pour afficher les services « en cours d’exécution » sous la colonne état. Bon maintenant il va falloir chercher la ligne « Service de l’agent de déploiement Web« , cliquez droit sur sa mauvaise tête de délinquant juvénile et désactivez-le une bonne fois pour toute (c’est qui le patron bordel).

On redémarre (ça ne mange pas de pain) et on relance WAMP. Là le miracle devrait se produire. Cette merveilleuse icone devrait enfin passer au vert. A vous les femmes, la gloire et l’argent ! 

Si ce n’est toujours pas le cas, appuyez sur les touches Windows + R, tapez services.msc, triez la liste par Nom et recherchez wampapache et wampmusqld. Les deux doivent avoir le statut « démarrer » pour que cela fonctionne. Si ce n’est pas le cas cela veut dire qu’il y a toujours un logiciel qui bloque le lancement de ces services. Le plus simple est d’en désinstaller un par un, en commençant par celui qui vous semble le plus à même de poser soucis. Généralement commencez par les bouts de logiciels ayant SQL ou Server dans leur intitulé… C’est fou toutes les cochonneries que les logiciels Microsoft les plus anodins peuvent laisser derrière eux…

 

Le petit truc (en fait deux) en plus parce que c’est jour de fête

Ah si encore un dernier truc si vous êtes sur Windows 7 ou 8, histoire d’être vraiment pénible, il est très possible que vous ne puissiez pas accéder à PHP my admin via http://localhost/phpmyadmin/. De deux choses l’une, soit cela ne vous embête pas plus que ça de taper des chiffres et ça devrait fonctionner en se connectant sur http://127.0.0.1/phpmyadmin, soit cela vous saoule profondément et une petite modification dans le fichier httpd.conf devrait vous sauver.

Pour y accéder, rebelote du clic gauche sur le W de la mort, menu Apache et clic sur httpd.conf. Là dans ce merveilleux fichier texte aussi distrayant qu’un document Excel de votre comptable, vous devriez avoir une ligne Listen 80. Remplacez là par la ligne : Listen 127.0.0.1:80 et c’est good to go comme disent les français qui font semblant de parler anglais.

Ah oui et si jamais vous avez l’erreur:

#1045 – Access denied for user ‘root’@’localhost’ (using password: NO) » 

n’oubliez pas d’installer le service MySQL. Pour cela cliquez gauche sur le W, puis MySQL, puis Services et enfin « install service« . Redémarrez Wamp, cela devrait résoudre le problème simplement.

 

Un dernier pour la route ?

Après avoir tapé sur Microsoft (parce que c’est tout de même sympa), je vous invite à essayer Webmatrix, dont la troisième version vient de sortir. C’est un genre d’IDE pour les gens pas doués comme moi, qui permet, en un tour de main, d’installer un serveur local ainsi qu’une bonne dizaine de CMS, sans avoir à se soucier de la configuration de quoi que soit. Vraiment pas mal foutu. Le seul souci c’est que pour le déploiement de votre site il vous impose de passer par ses paramétrages propriétaires. Genre j’ai envie de publier mon site sur Azure blablabla. Non mais allo quoi…

 

bereal

The web is a nice place to chill.

 

6 thoughts on “WAMP refuse de démarrer !

  1. J’ai été il y a quelques mois confronté à ce genre de problème, ce qui m’a valu une multitude de crise de nerfs ! J’ai finalement décidé de migrer vers Xampp après tant de difficultés avec Wamp, et je n’y ai pas noté de grands changements, cependant ce tutoriel m’est utile si je décide de repasser sur Wamp. Merci !

  2. j’ai édité l’article avec des précisions concernant les services incriminés. Egalement une petite note pour le message d’erreur #1045 – Access denied for user ‘root’@’localhost’ (using password: NO) » qui survient fréquemment après installation.

  3. Comme le dit Tristan, Xampp est également une valeur sûre du développement. Wamp plante souvent (il refuse de démarrer), tandis que Xampp ne plante presque jamais. Je viens tout juste de migrer et je ne suis pas déçu, cependant ce tutoriel m’a aidé à faire remarcher Wamp. Je met le site dans mes favoris, on sait jamais. Merci !

  4. C’est toujours un plaisir de lire tes trouvailles! Concernant Wamp, il fait un peu peur mais si tu as la recette miracle on pourrait toujours le revisiter histoire de s’en faire une idée et de décider si on le jette définitivement à la poubelle ou pas.

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée.